$re = '/((?<=\{\{)[^.{}]+)|(\.([^{}]+)\{([^{}]+)\})/';
$str = '{{variable.function1{param1}.function2{param2}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);