import re
regex = re.compile(r"^\w+(?:[.\-+!%]\w+)*@\w+(?:[.\-]\w+)+$", flags=re.MULTILINE)
test_str = ("djsuhuh@gmail.com\n"
"jdh0-@gmail.com\n"
"gdfsr!@yahoo.com\n"
"dhalfush%bvc@gmail.com\n"
"jgff-dhdhdg-hhh@gmail.com\n"
"example.index@gmai.com\n"
"lurdes@gmail.com\n"
"marina-souza@example.com\n"
"dhsu!jama@exam.com\n\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")