import re
regex = re.compile(r"(\d+\.)-?(\d+)%")
test_str = "P 0.0 2 576233 5322262 349781 167393 0 39965 216687 1740539 132012 66156 0 13006 (radio 8.-652% / 10.12% tx 5.93% / 6.74% listen 2.83% / 3.38%)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")