re = /(?=^\/\/).*/m
str = 'http://google.com
// this is a single line comment'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result