re = /.*?(?=%([0-9.]*)([lhjztL]*)([cCdiouxXeEfgGaAnpsSZRr]))/
str = '
arg % %1586lld asd %d
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end