package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\d+\.)+(.*)(?:\.\d+)+`)
var str = `09.04.EXAMPLETEXT.14`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}