$re = '/^\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}$/m';
$str = '1.0.0.0
1.0.0..';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);