import Foundation
let pattern = ##"((http(s)?|ftp)?:\/\/|www\.)dc([0-9])+\.4shared\.com\/([a-z0-9\/@#$,%*_-])+\.?(mp3|mp4|pdf|txt|doc|pps|epub|png|gif|jpg|jpeg|3gp|avi|mpg|wmv|mov|mkv|apk)?"##
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
http://dc778.4shared.com/img/4wW4UT5jba/9f90279b/dlink__2Fdownload_2F4wW4UT5jba_3Ftsid_3D20150615-114008-b7f2dbf8_26lgfp_3D1000_26sbsr_3D7c546ac8da497fae73b10095dc49e8d24e610417724fcf65/preview.wmv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}