$re = '~^(?=(ident)|\s+(ident))~m';
$str = 'ident
ident
ident
// ident
//ident
blah_ident';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);