using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-*[0-9]+[.]*[0-9]*";
string input = @"156.32343234124 dfsfsf -123.32424124 esfdfd 32.2342523";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}