$re = '/(?s)(?:\\\\.|[^\\\\|])+/m';
$str = 'A|B\\|C\\\\|D\\\\\\|E\\\\\\\\|F';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);