#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<url>(https?:.//?|www\.).*?)(?:</ref>)"
Local $sString = "=== Cette page est utilisé pour tester un maximum de scénarios différents pour l'outil WikiRef. ===" & @CRLF & _
"=== <u>Merci de ne pas y toucher</u> ===" & @CRLF & _
"" & @CRLF & _
"<ref>Melon busk + shorten domain https://www.youtube.com/watch?v=2j3p_aDMTNg</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>vidéo privé http://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>rick roll http://youtu.be/dQw4w9WgXcQ?feature=youtube_gdata_playe</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>ajout source redirect home page - http://youtube.com/watch?vi=dQw4w9WgXcQ&feature=youtube_gdata_player</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>rick roll avec share https://youtube.com/shorts/dQw4w9WgXcQ?feature=share'</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>Video indisponible (pas TOS, pas privé) - https://www.youtube-nocookie.com/embed/up_lNV-yoK4?rel=0%2C</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>lien de chaine https://www.youtube.com/user/Scobleizer#p/u/1/1p3vcRhsYGo</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>chaine indisponnible http://www.youtube.com/ytscreeningroom?v=NRHVzbJVx8I</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>video indisponnible https://www.youtube.com/watch?v=yZ-K7nCVnBI&playnext_from=TL&videos=osPknwzXEas&feature=sub</ref>" & @CRLF & _
"" & @CRLF & _
"<ref>Embedded video https://www.youtube.com/embed/nas1rJpm7wY?rel=0</ref>" & @CRLF & _
"" & @CRLF & _
"<ref> Multiple url reference [https://www.youtube.com/watch?v=ubNF9QNEQLA, https://www.youtube.com/watch?v=ubNF9QNEQLA]</ref>" & @CRLF & _
"" & @CRLF & _
"<ref> nowiki referefence <nowiki>https://www.youtube.com/watch?v=ubNF9QNEQLA</nowiki></ref>" & @CRLF & _
"" & @CRLF & _
"<references />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")