$re = '/(?<=<Code>).*(?=<\/Code>)/m';
$str = '<?xml version=\\"1.0\\" encoding=\\"UTF-16\\" ?><Codici QuoteParams><Code>AC-ALTRE-SPESE-T</Code></Codici QuoteParams>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);