$re = '/^(?=.*[a-zA-Z])[A-Za-z \'-]+$/m';
$str = 'test user
test1user
test user
- ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);