$re = '~(\d+)$~';
$str = '/bla/bla/bla/20160306';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);