import re
regex = re.compile(r"^\d{10}-\d{3}$", flags=re.MULTILINE)
test_str = ("989891832213213\n"
"987-12-1234\n"
"12-2343244\n"
"123123--123\n"
"1234567890-123\n"
"1234476895-120")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")