package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^\S).+ (\S)`)
var str = `Максим Петров`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}