$re = '/.*\KONE(?:(?!ONE).)*/m';
$str = 'ONE;TWO;THREE;ONE;FOUR;FIVE
TEST
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);