import Foundation
let pattern = #"(?<=\<h1\>).+(?=\<\/h1\>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<h1>COVEMA</h1>
<h1>PALMERO</h1>
<h1>PLASTIFERRO</h1>
<h1>UOCRA</h1>
<h1>REPAS</h1>
<h1>BTU</h1>
<h1>PANEDILE</h1>
<h1>ELEPRINT</h1>
<h1>JOSÉ J. CHEDIACK</h1>
<h1>NIRO CONSTRUCCIONES</h1>
<h1>HELPORT</h1>
<h1>BISCAYNE</h1>
<h1>COARCO</h1>
<h1>ESUCO</h1>
<h1>CPC</h1>
<h1>TEL 3</h1>
<h1>CARTELLONE</h1>
<h1>MACRO</h1>
<h1>VIAL AGRO</h1>
<h1>ISOLUX CORSÁN</h1>
<h1>AFCP</h1>
<h1>FINNING</h1>
<h1>ROGGIO</h1>
<h1>ROVELLA CARRANZA</h1>
<h1>ACINDAR</h1>
<h1>IERIC</h1>
<h1>IGARRETA MÁQUINAS</h1>
<h1>RIVA</h1>
<h1>GRUPO ESTISOL</h1>
<h1>IECSA</h1>
<h1>ARMAFERRO</h1>
<h1>BRICONS</h1>
<h1>CNH INDUSTRIAL</h1>
<h1>PAOLINI</h1>
<h1>SERVIUR</h1>
<h1>SANDVIK</h1>
<h1>DECAVIAL</h1>
<h1>ODEBRECHT</h1>
<h1>ENAS</h1>
<h1>SITRA</h1>
<h1>SUPERCEMENTO</h1>
<h1>JCR</h1>
<h1>CONSTRUMEX</h1>
<h1>BRIALES</h1>
<h1>CAPUTO</h1>
<h1>LUCIANO</h1>
<h1>GALICIA</h1>
<h1>VICTOR CONTRERAS</h1>
<h1>SIKA ARGENTINA</h1>
<h1>CRIBA</h1>
<h1>BOETTO Y BUTTIGLIENGO</h1>
<h1>MILICIC</h1>
<h1>PERIODICO EL CONSTRUCTOR</h1>
<h1>PHONERENTAL</h1>
<h1>DOS ARROYOS</h1>
<h1>MARTINEZ Y DE LA FUENTE</h1>
<h1>AUSA</h1>
<h1>LUIS LOSI</h1>
<h1>AESA</h1>
<h1>CONSTRUCTORA SUDAMERICANA</h1>
<h1>PLANTEL</h1>
<h1>PCR</h1>
<h1>BANCO DE LA NACIÓN ARGENTINA</h1>
<h1>SUBTERRÁNEOS DE BUENOS AIRES</h1>
<h1>HOLA SIM</h1>
<h1>JOSÉ LUIS TRIVIÑO</h1>
<h1>TECHINT</h1>
<h1>EDUARDO COLOMBI</h1>
<h1>ALEMARSA</h1>
<h1>CENTRO CONSTRUCCIONES</h1>
<h1>TECNIPISOS</h1>
<h1>XAPOR</h1>
<h1>FONTANA NICASTRO</h1>
<h1>CONCRET-NOR</h1>
<h1>DYCASA</h1>
<h1>BURGWARDT</h1>
<h1>SULLAIR</h1>
<h1>FONDO FIDUCIARIO FEDERAL DE INFRAESTRUCTURA REGIONAL</h1>
<h1>FLOWTEX</h1>
<h1>PETERSEN THIELE Y CRUZ</h1>
<h1>LIHUÉ</h1>
<h1>IRAM</h1>
<h1>ESTUDIO YMAZ</h1>
<h1>VIDOGAR</h1>
<h1>BICE</h1>
<h1>ROMERO CAMMISA</h1>
<h1>BATIMAT</h1>
<h1>ALBA CAUCIÓN</h1>
<h1>PROBA</h1>
<h1>ICF</h1>
<h1>TECMA</h1>
<h1>ALESTE</h1>
<h1>DELEGACIÓN PROVINCIA DE BUENOS AIRES</h1>
<h1>HIDRAVIAL</h1>
<h1>BANCO CIUDAD</h1>
<h1>LAMANNA</h1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)