import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ENV GOSS_VERSION=\"(?<currentValue>.*)\"";
final String string = "FROM kudobuilder/kuttl:v0.15.0\n\n"
+ "ENV GOSS_VERSION=\"v0.3.20\"\n"
+ "ENV KUTTL_VERSION=\"v0.44.0\"\n\n"
+ "# curl -LO https://storage.googleapis.com/kubernetes-release/release/v1.26.0/bin/linux/amd64/kubectl && \\\n"
+ "# chmod +x ./kubectl && \\\n"
+ "# mv ./kubectl /usr/local/bin/kubectl && \\\n\n\n"
+ "# Pending merge of https://github.com/goss-org/goss/pull/792 and https://github.com/kudobuilder/kuttl/pull/448\n"
+ "RUN echo \"Installing carvel ytt version ${KUTTL_VERSION}\" ; \\\n"
+ " curl -L \"https://github.com/goss-org/goss/releases/download/${KUTTL_VERSION}/ytt-linux-amd64\" -o /usr/local/bin/ytt && \\\n"
+ " chmod +rx /usr/local/bin/ytt && \\\n"
+ " echo \"Installing goss and kgoss version ${GOSS_VERSION}\" ; \\\n"
+ " curl -L \"https://github.com/goss-org/goss/releases/download/${GOSS_VERSION}/goss-linux-amd64\" -o /usr/local/bin/goss && \\\n"
+ " chmod +rx /usr/local/bin/goss && \\\n"
+ " curl -LO https://raw.githubusercontent.com/orange-cloudfoundry/goss/kgoss-kubectl-opts/extras/kgoss/kgoss -o /usr/local/bin/kgoss && \\\n"
+ " chmod +rx /usr/local/bin/kgoss && \\\n"
+ " /usr/local/bin/ytt --version && \\\n"
+ " /usr/local/bin/goss -v && \\\n"
+ " /usr/local/bin/kubectl version && \\\n"
+ " /usr/local/bin/kgoss || echo \"Installation done.\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}