$re = '/(c?)(h?)(e?)(r?)(r?)(b?)/';
$str = 'berry';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);