package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^()]*\([^()]*\),?`)
var str = `Titanium Dioxide (CI 77897), Black 2 (CI 77266), Iron Oxides (CI 77491, 77492, 77499), Ultramarines (CI 77007)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}