re = /,\s*(?![^()]*\))/m
str = 'Water, Titanium Dioxide (CI 77897), Black 2 (CI 77266), Iron Oxides (CI 77491, 77492, 77499), Ultramarines (CI 77007)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end