package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[+\-*^/()]|([0-9.]+)`)
var str = `41*(5.5+6-(8/2^3)-7)-1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}