$re = '~^(?:тест)?+\K(.+)\sот~m';
$str = 'Текст от и до
тест от и до
Текст от и до';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);