re = /contra?.\s+?(\d*\.?\d+)(.+(mafo)?.?\s+(\d*\.?\d+))?/m
str = 'numb contra: 1.29151306 number mafo: 66662308
numb contra 1.30789668number mafo 60.046483
numb contra/ 1.29154056 number mafo: 666692638
numb contra 137459625
mafo: 666692638
mafo: 666692638 numb contra/ 1.29154056'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end