re = /^(?!.*timescale).*duration:/m
str = 'duration: 2000
duration: 3000 timescale
timescale duration: 3000
duration: 5000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end