$re = '/"(AWS::.*?)"/';
$str = '"AWS::EC2::KeyPair::KeyName"
"test"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);