re = /animals\.(?!elephant\b)\w+/
str = 'animals.fox
=> Result: animals.fox
animals.kitten
=> Result: animals.kitten
animals.elephant '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end