$re = '/(?=.*[A-Z])(?=.*[a-z])(?=.*[0-9]).*/m';
$str = 'abcdefg12121211';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);