using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the game (.*?)\s+?on";
string input = @"the game list
on";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}