const regex = /##,imei:(\d+),A/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('##,imei:(\\d+),A', '')
const str = `##,imei:359586015829802,A;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}