package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{5}`)
var str = `00244`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}