$re = '/(?<!plus.google.com)\b(?:\/.*)\b/';
$str = 'plus.google.com/7465486587456
www.meh.com/47654876548';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);