const regex = /^ *(\d{4}-?)?\d{2}-?\d{3}-?\d{4} *$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ *(\\d{4}-?)?\\d{2}-?\\d{3}-?\\d{4} *$', '')
const str = `1234-99-123-4567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}