package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.{1,20})(?:\s|$)`)
var str = `I have String Search the whole web or only webpages After doing some research I think that I want to combine an if/then statement with lookahead, i.e. go to the character limit and if there is a character following it that is a space, add an ellipses, if it is a number or letter, go to the final space within the limit and add an ellipses`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}