package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.{1,20})(?:\s|$)`)
var str = `1212
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}