package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s|^)((?:\+|-)?\d+(?:\.\d+)?)(?:\s|$)`)
var str = ` li 12.12 si 43,23 45 31 uf 889 uf31 3.12345 12.34# 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}