package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^#]*+(.*)$`)
var str = `http://localhost/search/s.php?search_query=#hashtag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}