import re
regex = re.compile(r"(@.*?:[^}{@]+(\{(?:[^}{]+|\{(?:[^}{]+|\{[^}{]*\})*\})*\}))")
test_str = ("CSS @media selector\n"
".CSS Code sample test\n"
"@media screen and (min-width:0) and (max-width:640px) {\n"
" body.overlap .page-title .wf-wrap {\n"
" padding-top: 0!important;\n"
" padding-bottom: 4px!important\n"
" }\n"
" .h3-size {\n"
" font: normal 17px / 21px \"Roboto\",Helvetica,Arial,Verdana,sans-serif!important\n"
" }\n"
" body.breadcrumbs.breadcrumbs-bg {\n"
" margin-top: 0!important\n"
" }\n"
" .page-title .breadcrumbs,.page-title .breadcrumbs a {\n"
" font-size: 11px!important\n"
" }\n"
"}\n"
"@-webkit-keyframes fadeIn {0% { opacity: 0; }100% { opacity: 1; }}\n\n"
"@media screen and (max-width:200px){.sidebar-content {margin-bottom:20px}\n"
".cat-item {padding:7px}\n"
".widget_1 {padding-right:0}\n"
"}\n"
"/* TEST NESTED @media: */\n"
"@media screen and (max-width:200px){.sidebar-content {margin-bottom:20px}\n"
".cat-item {padding:7px}\n"
"/* TEST NESTED @media capturing everything, comments too */\n"
"@media screen and (max-width:359px){.sidebar-content {margin-bottom:20px}\n"
".cat-item {padding:7px}\n"
".widget_1 {padding-right:0}\n"
"}\n"
".widget_1 {padding-right:0}\n"
"}\n"
"@font-face { font-family: dashicons; src: url(\"https://emd4.com/\"); }\n"
".h3-size {\n"
" font-style: normal\n"
"}\n"
"@media(min-width:768px){.vc_col-sm-1,.vc_col-sm-10,.vc_col-sm-11,.vc_col-sm-12,.vc_col-sm-2,.vc_col-sm-3,.vc_col-sm-4,.vc_col-sm-5,.vc_col-sm-6,.vc_col-sm-7,.vc_col-sm-8,.vc_col-sm-9{float:left}\n"
".vc_col-sm-12{width:100%!important}\n"
".vc_col-sm-11{width:91.66666667%}\n"
".vc_col-sm-10{width:83.33333333%}\n"
".vc_col-sm-9{width:75%}\n"
".vc_col-sm-8{width:66.66666667%}\n"
".vc_col-sm-7{width:58.33333333%}\n"
".vc_col-sm-6{width:50%}\n"
".vc_col-sm-5{width:41.66666667%}\n"
".vc_col-sm-4{width:33.33333333%}\n"
".vc_col-sm-3{width:25%}\n"
".vc_col-sm-2{width:16.66666667%}\n"
".vc_col-sm-1{width:8.33333333%}\n"
".vc_col-sm-pull-12{right:100%}\n"
".vc_col-sm-pull-11{right:91.66666667%}\n"
".vc_col-sm-pull-10{right:83.33333333%}\n"
".vc_col-sm-pull-9{right:75%}\n"
".vc_col-sm-pull-8{right:66.66666667%}\n"
".vc_col-sm-pull-7{right:58.33333333%}\n"
".vc_col-sm-pull-6{right:50%}\n"
".vc_col-sm-pull-5{right:41.66666667%}\n"
".vc_col-sm-pull-4{right:33.33333333%}\n"
".vc_col-sm-pull-3{right:25%}\n"
".vc_col-sm-pull-2{right:16.66666667%}\n"
".vc_col-sm-pull-1{right:8.33333333%}\n"
".vc_col-sm-pull-0{right:auto}\n"
".vc_col-sm-push-12{left:100%}\n"
".vc_col-sm-push-11{left:91.66666667%}\n"
".vc_col-sm-push-10{left:83.33333333%}\n"
".vc_col-sm-push-9{left:75%}\n"
".vc_col-sm-push-8{left:66.66666667%}\n"
".vc_col-sm-push-7{left:58.33333333%}\n"
".vc_col-sm-push-6{left:50%}\n"
".vc_col-sm-push-5{left:41.66666667%}\n"
".vc_col-sm-push-4{left:33.33333333%}\n"
".vc_col-sm-push-3{left:25%}\n"
".vc_col-sm-push-2{left:16.66666667%}\n"
".vc_col-sm-push-1{left:8.33333333%}\n"
".vc_col-sm-push-0{left:auto}\n"
".vc_col-sm-offset-12{margin-left:100%}\n"
".vc_col-sm-offset-11{margin-left:91.66666667%}\n"
".vc_col-sm-offset-10{margin-left:83.33333333%}\n"
".vc_col-sm-offset-9{margin-left:75%}\n"
".vc_col-sm-offset-8{margin-left:66.66666667%}\n"
".vc_col-sm-offset-7{margin-left:58.33333333%}\n"
".vc_col-sm-offset-6{margin-left:50%}\n"
".vc_col-sm-offset-5{margin-left:41.66666667%}\n"
".vc_col-sm-offset-4{margin-left:33.33333333%}\n"
".vc_col-sm-offset-3{margin-left:25%}\n"
".vc_col-sm-offset-2{margin-left:16.66666667%}\n"
".vc_col-sm-offset-1{margin-left:8.33333333%}\n"
".vc_col-sm-offset-0{margin-left:0}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")