use strict;
my $str = 'red
#f00
#ff0000
rgb(255,0,0)
rgb(100%, 0%, 0%)
hsl(0, 100%, 50%)
hsl(0., 100%, 50%)
hsl(.0, 100%, 50%)
hsl(0.0, 100%, 50%)
rgba(255, 0, 0, 0.5)
hsla(0, 100%, 50%, 0.5)
red
orange
antiquewhite
#0f0
#00ff00
rgba( 34, 12, 64, 0.3)
currentcolor
inherit
initial
unset';
my $regex = qr/(?#https://regex101.com/r/eO8pP0/)(?(DEFINE)(?<hex>[a-fA-F\d])(?<hue>[+-]?(?:\d{1,8}(?:\.\d{0,8})?|\.\d{0,8}))(?<percent>(?:\d{1,2}|100)%)(?<channel>(?&percent)|25[0-5]|2[0-4]\d|[0-1]\d\d|\d{1,2})(?<rgb>\h*(?&channel)\h*(?:,\h*(?&channel)\h*){2})(?<hsl>\h*(?&hue)\h*(?:,\h*(?&percent)\h*){2})(?<alpha>1(?:\.0*)?|0?\.\d{1,8}|0))^(?:#(?:(?&hex){6}|(?&hex){3})|rgb\h*\((?&rgb)\)|hsl\h*\((?&hsl)\)|rgba\h*\((?&rgb),\h*(?&alpha)\h*\)|hsla\h*\((?&hsl),\h*(?&alpha)\h*\)|inherit|initial|transparent|unset|current[cC]olor|(?# Named colors)aliceblue|antiquewhite|aqua|aquamarine|azure|beige|bisque|black|blanchedalmond|blue|blueviolet|brown|burlywood|cadetblue|chartreuse|chocolate|coral|cornflowerblue|cornsilk|crimson|cyan|darkblue|darkcyan|darkgoldenrod|darkgray|darkgreen|darkgrey|darkkhaki|darkmagenta|darkolivegreen|darkorange|darkorchid|darkred|darksalmon|darkseagreen|darkslateblue|darkslategray|darkslategrey|darkturquoise|darkviolet|deeppink|deepskyblue|dimgray|dimgrey|dodgerblue|firebrick|floralwhite|forestgreen|fuchsia|gainsboro|ghostwhite|gold|goldenrod|gray|green|greenyellow|grey|honeydew|hotpink|indianred|indigo|ivory|khaki|lavender|lavenderblush|lawngreen|lemonchiffon|lightblue|lightcoral|lightcyan|lightgoldenrodyellow|lightgray|lightgreen|lightgrey|lightpink|lightsalmon|lightseagreen|lightskyblue|lightslategray|lightslategrey|lightsteelblue|lightyellow|lime|limegreen|linen|magenta|maroon|mediumaquamarine|mediumblue|mediumorchid|mediumpurple|mediumseagreen|mediumslateblue|mediumspringgreen|mediumturquoise|mediumvioletred|midnightblue|mintcream|mistyrose|moccasin|navajowhite|navy|oldlace|olive|olivedrab|orange|orangered|orchid|palegoldenrod|palegreen|paleturquoise|palevioletred|papayawhip|peachpuff|peru|pink|plum|powderblue|purple|red|rosybrown|royalblue|saddlebrown|salmon|sandybrown|seagreen|seashell|sienna|silver|skyblue|slateblue|slategray|slategrey|snow|springgreen|steelblue|tan|teal|thistle|tomato|turquoise|violet|wheat|white|whitesmoke|yellow|yellowgreen)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}