$re = '/@[^,]+/m';
$str = 'email1@uy.com, email2@iu.it, email3@uu.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);