package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\w]+\.asp`)
var str = `/blog/vendita_mobili_grezzi.asp`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}