import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<script\\>[^<]*?(findthis).*?\\<\\/script\\>";
final String string = "<html>\n"
+ " <head>\n"
+ " <script>\n"
+ " var x = 1;\n"
+ " var y = 'findthis'; // Should be matched\n"
+ " </script>\n"
+ " </head>\n"
+ " <body>\n"
+ " <script>\n"
+ " var a = 2;\n"
+ " </script>\n\n"
+ " <h1>Welcome!</h1>\n"
+ " <p>This findthis here should not be matched.</p>\n\n"
+ " <script>\n"
+ " var b = 'findthis too'; // Should be matched, too.\n"
+ " </script>\n\n"
+ " <div>\n"
+ " <p>This findthis should not be matched neither.</p>\n"
+ " </div>\n"
+ " </body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}