$re = '/"([^"]*)"/';
$str = 'file "/var/project/extra_file.log" 5335;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);