import re
regex = re.compile(r"[^GWDF](?!.?4)[0-9DTSRF]+")
test_str = "G4 G4 G7 G9 G9 R3 B4 RD2 R3 YD2 R4 R5 RR W BDT Y0 YS G8 WDF"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)