$re = '/<style\s?(?!\/>)/';
$str = '<style type=\\"text/html\\">ciaoxocs <style />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);