re = /((?:(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5]))/
str = '1.2.3.4 kjhkjhjkh kj8.8.8.8hjfjhg 7.7.7.7..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end