using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!"").*?(\[\[.*?\]\])(?!.*"")";
string input = @"[[Hello]]
<tag Text=""my [[Test]] is [[Test2]] for [[Test3]][[Test4]]"">
<tag Text=my [[Test]] is [[Test2]] for [[Test3]][[Test4]]>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}