$re = '/^(?!.*?(?:bob|alice|kitty)).*$/m';
$str = 'bob
alice
john
kitty
I am bob';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);